$re = '/^\d{3}-\d{2}-\d{4}$/m';
$str = '555-55-5555
11111111
111-111-1111
111-22-5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);