re = /^(\d+[\s\r\n\t,]*){1,100}$/i
str = '02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1012312313123131232102241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end