const regex = /star\s[a-zA-Z0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('star\\s[a-zA-Z0-9]', 'gm')
const str = `<div class="author">
<a href="/member/?id=59465221" target="_blank">唐牛</a>
<span class="star0 sa2"></span></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}