package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`if\s*\(\s*([^\s\)]+)\)\s*\{`)
var str = `if(a){
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}