#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:[_-]$|_ | _))[a-zA-Z][\w -]*$"
Local $sString = " // Match" & @CRLF & _
"A" & @CRLF & _
"HelloWorld" & @CRLF & _
"Hello_-World" & @CRLF & _
"Hello_World_1" & @CRLF & _
"He110_W0rld" & @CRLF & _
"Hello - World" & @CRLF & _
"Hello-World" & @CRLF & _
"" & @CRLF & _
" // doesn't match" & @CRLF & _
"Hello _World" & @CRLF & _
"Hello_ World" & @CRLF & _
"Hello _ World" & @CRLF & _
"_HelloWorld"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")