package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\sx\s(?:[0-9]{2}\s){2}(.*?)\s[\w]{3,}`)
var str = `22.665774 Fr RMSG 0 0 1 1 18 11 Rx 0 308002 5 20 1d6 x 20 20 a8 4f 35 40 1b 00 0f 08 f7 89 ff fa ff f3 35 80 49 00 00 00 00 30 00 00 80 ab 4b 54 40 f0 00 fc 714a81 1 40937`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}