$re = '/^(?=.*\broll\b)(?=.*\bover\b).+|^(?=.*\brollover\b).+/m';
$str = 'hello meat pasta dinner what roll over?
hello meat pasta dinner what rollover?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);