using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/tenor\.com\/(?:[a-z]{2}(?:-[A-Z]{2})?\/)?view\/(?P<image_slug>[a-zA-Z0-9%-]+-(?P<image_id>\d+))";
string input = @"https://tenor.com/es-ES/view/baka-idiot-anime-gif-16811539
https://tenor.com/bg/view/baka-idiot-anime-gif-16811539
https://tenor.com/de/view/baka-idiot-anime-gif-16811539
https://tenor.com/zh-CN/view/baka-idiot-anime-gif-16811539
https://tenor.com/view/frieren-%E8%91%AC%E9%80%81%E3%81%AE%E3%83%95%E3%83%AA%E3%83%BC%E3%83%AC%E3%83%B3-sousou-no-frieren-sousou-beyond-journey%27s-end-gif-13214487266596803271";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}