$re = '/\d+(\.\d+)?\s*-\s*\d+(\.\d+)?/m';
$str = '23.566
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);