$re = '/^(?:[[:alnum:]]+-)?\K[0-9]+/m';
$str = '2020.80-suffix-1
2020.80-suffix
prefix-2020.80
prefix-2020.80-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);