$re = '~(?s).*?<(\S+?)[^>]*>.*?</\1>.*~';
$str = '<abc id="123">foo bar</abc>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);