const regex = /^[a-f0-9]{32}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-f0-9]{32}$', 'i')
const str = `e10adc3949ba59abbe56e057f20f8832`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}