re = /^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[#!*@$%^&()\-_]+)[A-Za-z\d#!*@$%^&()]{8,16}$/m
str = 'Abcde123!
ABCDEF3@
Aghjd&ty1&&
abnmbus7###'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end