$re = '/^(^$|[1][9][6-9]\d|[2][0][0]\d|[2][0][1][0-7]|[1][9][6-9]\d[\/\-]([0][0-9])|([1][0-2])|[2][0][0-2]\d[\-]([0][0-9])|([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01])))$/m';
$str = '1999-13-02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);