import re
regex = re.compile(r"(\$[^\n$]*[^\s$])(-|=|\+)([^\s$][^\n$]*\$)")
test_str = ("\\end{theorem}\n\n"
" A $k$-periodic sequence has the property that $s_i = s_{i + k}$ for all $i = 0,1,\\dots$.\n"
" Thus a $k$-periodic sequence $(s_i)_{i = 0}^\\infty$ may be represented by any finite sequence $(s_i)_{i=a}^{a+k - 1}$, where $a$ is usually chosen to be $0$.\n"
" \n"
" Sadly our Fibonacci sequence examples are not defined over a finite field but over the naturals and thus are not necessarily periodic.\n"
" Examples such as these may be interpreted to have a period of $\\infty$. \n"
" \n"
" The period and related stability of linear recurrence sequences in regard to linear complexity has a very rich and broadly studied background~\\cite{DingZiaoShan1991}.\n"
" \n"
" \\begin{theorem}\n"
" \\label{th: max period is m-sequence}\n"
" \\cite[Theorem~6.33]{LidlNiederreiter1994}\n"
" A linear recurrence sequence $s$ over a finite field $\\gf_2$ with linear complexity $n$ has a maximum possible period of $2^n-1$.\n"
" \\end{theorem}\n"
" \n"
" \\begin{definition}\n"
" \\label{de: m-sequence}\n"
" A sequence which has maximum period for giv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")