#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "BEGN: ([^D]*(?:D(?!ETAIL:)[^D]*)*)"
Local $sString = "BEGN: text" & @CRLF & _
"textDETAIL:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")