package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Q()\E`)
var str = `rawr()arawrae()()(())`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}