#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([2-6]ª[-feira]{0,})|^(segunda|terça|quarta|quinta|sexta)\b[-feira]{0,}"
Local $sString = "2ª" & @CRLF & _
"3ª" & @CRLF & _
"4ª" & @CRLF & _
"5ª" & @CRLF & _
"6ª" & @CRLF & _
"2ª-feira" & @CRLF & _
"3ª-feira" & @CRLF & _
"4ª-feira" & @CRLF & _
"5ª-feira" & @CRLF & _
"6ª-feira" & @CRLF & _
"segunda" & @CRLF & _
"terça" & @CRLF & _
"quarta" & @CRLF & _
"quinta" & @CRLF & _
"sexta" & @CRLF & _
"segunda-feira" & @CRLF & _
"terça-feira" & @CRLF & _
"quarta-feira" & @CRLF & _
"quinta-feira" & @CRLF & _
"sexta-feira" & @CRLF & _
"" & @CRLF & _
"____________Não_" & @CRLF & _
"oitava-feira" & @CRLF & _
"sexta-" & @CRLF & _
"sextafeira" & @CRLF & _
"-feira" & @CRLF & _
"feira" & @CRLF & _
"22ª" & @CRLF & _
"1ª" & @CRLF & _
"7ª" & @CRLF & _
"ª" & @CRLF & _
"2-feira" & @CRLF & _
"aquartado" & @CRLF & _
"sextavado"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")