$re = '/\b;\b/';
$str = 'today;i;;drank water;as';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);