re = /^(.+) = https:\/\/(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})$/m
str = 'LOCALHOST = https://192.168.56.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end