# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^#define (.*) (0x[0-9A-F]+)$/private const byte $1 = $2; \/\/ $1/gm;t' <<< "/* Sensor Binary command class commands */
#define SENSOR_BINARY_VERSION_V2 0x02
#define SENSOR_BINARY_GET_V2 0x02
#define SENSOR_BINARY_REPORT_V2 0x03
#define SENSOR_BINARY_SUPPORTED_GET_SENSOR_V2 0x01
#define SENSOR_BINARY_SUPPORTED_SENSOR_REPORT_V2 0x04
/* Values used for Sensor Binary Report command */
#define SENSOR_BINARY_REPORT_IDLE_V2 0x00
#define SENSOR_BINARY_REPORT_DETECTED_AN_EVENT_V2 0xFF
"