re = /(?<!\S)(?:javascript|c\+)(?!\S)/m
str = 'test c+ and javascript etc but NOT javascripter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end