$re = '/(?:^|[;\n]\s*)(--[\w-]*?):\s*(?:([^;{]*)|{([^}]*)})(?:(?=[;\n])|$)/i';
$str = '#gc4 {
--grand-child-scope-var:
var(--gc4-scope) ;
--grand-child-scope-var:
var(--gc4-scope);
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);