package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Z0-9]{3}:[A-Z0-9]{3}$`)
var str = `MAN:PES`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}