$re = '/([a-zA-Z][a-zA-Z0-9._$]+)\s*\(\s*([a-zA-Z0-9_$]+(?:\s*,\s*[a-zA-Z0-9_$]+)*)\s*\)/';
$str = 'methodName(as(s) , Util.test(sssssssssss ),abc());';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);