import re
regex = re.compile(r"((?<!\")(?:\"\")*\"(?!\"))")
test_str = "\"lol\" \"\"\"lol\"\"\"\"\" \"\"foo\"\" \"\"\"\"bar\"\"\"\"\"\"\"\"\""
subst = "$1\""
result = regex.sub(subst, test_str)
if result:
print(result)