re = /^4(?:\D*\d){15}$/m
str = '43 20 75 89 94 56 01 23
4 3 2 0 7 5 8 9 9 4 5 6 0 1 2 3
4320a7589b9456c0123
4320$7589$9456$0123
4320_7589_9456_0123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end