package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^the`)
var str = `they saw the trees at hill station.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}