package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ab)+c`)
var str = `abbbc ac abc abababc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}