package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[{2}(.*)\|(.*)]]\z`)
var str = `[[Identity (philosophy)|unique identity]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}