$re = '/(?> (?P<L> ¬? (?> [A-Z⊥]| \((?R)\) ) )[↔∧∨→])?\g<L>/x';
$str = 'P
⊥
¬Q
P∧Q
P∨(Q→R)
P∧(Q∧R)
¬P∨¬(Q∧R)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);