$re = '/\b(?!\w*ab\w*ab)\w*ab\w*/m';
$str = 'aaaabaaa
ab
abomination
and not these:
something
abab
bacba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);