const regex = new RegExp('(Property\\sname:(\\w+))', 'gm')
const str = `Property:0x21207642, Property name:DI_INFO_SAFETY_WARNINGS_WARNING_SLIPPERY_CONDITIONS, access:0x1, changeMode:0x1, config:0x[], fs min:0.0, fs max:0.0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}