#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:font)[\ ]+([A-Za-z0-9\=\:]+)[\}\ \}]"
Local $sString = "conky.config = {" & @CRLF & _
"-- ------------------------- Windows Settings" & @CRLF & _
" own_window = true," & @CRLF & _
" own_window_type = 'normal'," & @CRLF & _
" own_window_transparent = false," & @CRLF & _
" own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager'," & @CRLF & _
" own_window_argb_visual = true," & @CRLF & _
" own_window_argb_value = 0," & @CRLF & _
"" & @CRLF & _
" double_buffer = true," & @CRLF & _
" background = true," & @CRLF & _
"" & @CRLF & _
"-- ------------------------- Position" & @CRLF & _
" alignment = 'bottom_left'," & @CRLF & _
"" & @CRLF & _
" minimum_width = 295," & @CRLF & _
" minimum_height = 155," & @CRLF & _
" maximum_width = 313," & @CRLF & _
"" & @CRLF & _
" gap_x = 1252," & @CRLF & _
" gap_y = 155," & @CRLF & _
"" & @CRLF & _
" border_inner_margin = 0," & @CRLF & _
" border_outer_margin = 0," & @CRLF & _
" border_width = 0," & @CRLF & _
"" & @CRLF & _
"-- ------------------------- Font" & @CRLF & _
" use_xft = true," & @CRLF & _
" xftalpha = 0.8," & @CRLF & _
" override_utf8_locale = true," & @CRLF & _
"" & @CRLF & _
" draw_shades = true," & @CRLF & _
" default_shade_color = 'black'," & @CRLF & _
"" & @CRLF & _
" draw_borders = false," & @CRLF & _
" draw_outline = false," & @CRLF & _
"" & @CRLF & _
" font = 'Monofur:bold:size=8'," & @CRLF & _
"" & @CRLF & _
"-- ------------------------- Color" & @CRLF & _
" default_color = 'DCDCDC'," & @CRLF & _
" color0 = '1793d0'," & @CRLF & _
" color1 = 'DDDDDD'," & @CRLF & _
" color2 = 'AAAAAA'," & @CRLF & _
" color3 = '888888'," & @CRLF & _
"" & @CRLF & _
"-- ------------------------- OTHER" & @CRLF & _
" update_interval = 1," & @CRLF & _
"" & @CRLF & _
" lua_load = '~/.conky/ConkyBar/lua/net_graph.lua'," & @CRLF & _
" lua_draw_hook_pre = 'main_graph'," & @CRLF & _
"" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"conky.text = [[" & @CRLF & _
"${color DCDCDC}" & @CRLF & _
"${color DCDCDC }" & @CRLF & _
"${if_existing /proc/net/route enp8s0}${voffset 25}${goto 50}${font}Network${image ~/.conky/ConkyBar/img/networkhigh.png -p 0,15}" & @CRLF & _
"${goto 50}${font}Public ip: ${font Monofur:size=8}${texeci 36000 wget -qO - http://ip.tupeux.com | tail}" & @CRLF & _
"${voffset 81}${goto 50}${font}Recieve: ${font Monofur:size=8}${downspeed enp8s0}${goto 210}${font}Send: ${font Monofur:size=8}${upspeed enp8s0}${else}${if_existing /proc/net/route wlp2s0}${voffset 25}${goto 50}${font}Network" & @CRLF & _
"${goto 50}${font}Public ip: ${font Monofur:size=8}${texeci 36000 wget -qO - http://ip.tupeux.com | tail}${goto 210}${font}Sign: ${font Monofur:size=8}${wireless_link_qual_perc wlp2s0}%" & @CRLF & _
"${voffset 81}${goto 50}${font}Recieve: ${font Monofur:size=8}${downspeed wlp2s0}${goto 210}${font}Send: ${font Monofur:size=8}${upspeed wlp2s0}" & @CRLF & _
"${if_match "${wireless_link_qual_perc wlp2s0}"<"33"}${image ~/.conky/ConkyBar/img/networklow.png -p 0,15 -s 45x45}${else}${if_match "${wireless_link_qual_perc wlp2s0}"<"66"}${image ~/.conky/ConkyBar/img/networkmid.png -p 0,15}${else}${image ~/.conky/ConkyBar/img/networkhigh.png -p 0,15}${endif}${endif}${else}${voffset 27}${goto 50}${font}Network${image ~/.conky/ConkyBar/img/nonetwork.png -p 0,15}" & @CRLF & _
"${goto 50}No connection${endif}${endif}" & @CRLF & _
"]];"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")