import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Updated IVR Info response to :)[^.]+";
final String string = "Updated IVR Info response to :Answered but No Response. Locked for IVR processing. \n"
+ "Updated IVR Info response to :Yes. Locked for IVR processing.\n"
+ "Updated IVR Info response to :No. Locked for IVR processing. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}