import re
regex = re.compile(r"href=\".[^\"]*facebook\.com\/(.[^\"]*)")
test_str = ("<div class=\"fb-page\" data-href=\"https://www.facebook.com/dreamsportingtrips\" data-tabs=\"timeline\" data-small-header=\"false\" data-adapt-container-width=\"true\" data-hide-cover=\"false\" data-show-facepile=\"true\"><div class=\"fb-xfbml-parse-ignore\"><blockquote cite=\"https://www.facebook.com/dreamsportingtrips\"><a href=\"https://www.facebook.com/dreamsportingtrips\">Dream Sporting Trips</a></blockquote></div></div>\n"
"<p>This works for links to facebook on images, or facebook widgets, etc</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")