# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z](\d\d?|[a-z]\d[a-z\d]?|[a-z]?\d?\d \d[a-z]{2}|[a-z]\d [a-z] \d[a-z]{2})$"
test_str = ("A0\n"
"B11\n"
"CC2\n"
"DD3D\n"
"EE44\n"
"F5 5FF\n"
"G77 7GG\n"
"HH8 8HH\n"
"II9 I 9II\n"
"JJ00 0JJ\n\n"
"00\n"
"0A\n"
"AA\n"
"111\n"
"1B1\n"
"11B\n"
"C1C\n"
"1CC\n"
"CCC\n"
"3333\n"
"D333\n"
"3D33\n"
"33D3\n"
"333D\n"
"E4E4\n"
"E44E\n"
"4EE4\n"
"4E4E\n"
"44EE\n"
"DDD3\n"
"D3DD\n"
"3DDD\n"
"DDDD\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.