import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\S{8,20}$)(?=\\D*\\d)(?![0-9_]).{6,18}?(.)\\1$";
final String string = "+234567899\n"
+ "a_1de*Gg\n"
+ "xy1Me*__\n"
+ "!41deF_hij2lMnopq3ss\n"
+ "C234567890123$^67800\n"
+ "*5555555\n"
+ "sDF564zer\"\"\n"
+ "!!!!!!!!!4!!!!!!!!!!\n"
+ "abcdefghijklmnopq9ss\n"
+ "a_1+Eff\n"
+ "B41def_hIJ2lmnopq3stt\n"
+ "abCDefghijklmnopqrss5\n"
+ "A_4 e*gg\n"
+ "__1+Eff\n"
+ "841DEf_hij2lmnopq3stt\n"
+ "a_1+eFg\n"
+ "b41DEf_hij2lmnopq3st\n"
+ "abCDefghijklmnopqrss\n"
+ "abcdef+++dF\n"
+ "!!!!!!!!!!!!!!!!!!!!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}