$re = '/^\+.*$/m';
$str = 'string
+another
1234
+1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);