using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +(?=(?:(?:[^""]*""){2})*[^""]*$)";
string input = @"a:0 b:1 moo:""foo bar"" c:2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}