re = /\((?:\([^()]*\)|[^()])*\)/m
str = 'ransformer Winding Connections (Wye (Star) or Delta)
Transformer Winding Connections (Wye (Star) or Delta (Something))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end