# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<![\s\S\r])(.*)"
test_str = ("# project1\n"
"I could have put any other inline tag or string there.\n"
"This main body line could have been the very first line as well, if no tags exist.\n\n"
"Change the keys after each `\\n` and add or remove any more keys you want.\n"
"In this example, I added the desired tag in the indented multi-line format favoured by Obsidian.\n"
"As this is not a Templater solution, `date modified` is hard-coded here for the date you are making your changes. If not needed, it can be removed for the substitution part. \n"
"If it is a first time doing regex changes, make a backup of vault or Diary folder.")
subst = "---\\naliases: \\ntopic: \\ntags: \\n - m/diary\\npublish: false\\ndate modified: 2023-09-21\\n---\\n\\n$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.