$re = '~(.+)[\r\n]?~';
$str = 'This is the program
Hello World';
$subst = "\1;\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;