#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+(?:th|st|[nr]d)?(?:-\d+(?:th|st|[nr]d)?)?\s*(?:APR|April))|((?:APR|April)\s*\d+(?:th|st|[nr]d)?(?:-\d+(?:th|st|[nr]d)?)?)"
Local $sString = "some garbagde . some garbagde 02 APR some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 02 some garbagde " & @CRLF & _
"some garbagde . some garbagde 2 APR some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 2 some garbagde" & @CRLF & _
"some garbagde . some garbagde 2nd APR some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 2nd some garbagde" & @CRLF & _
"some garbagde . some garbagde 2nd April some garbagde" & @CRLF & _
"some garbagde . some garbagde April 2nd some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 12th some garbagde" & @CRLF & _
"some garbagde . April 12th some garbagde" & @CRLF & _
"some garbagde . 12th April some garbagde" & @CRLF & _
"some garbagde . April 13-16 some garbagde" & @CRLF & _
"some garbagde . 13-16 April some garbagde" & @CRLF & _
"some garbagde . APR 13-16 some garbagde" & @CRLF & _
"some garbagde . 13-16 APR some garbagde" & @CRLF & _
"some garbagde . April 13th-16th some garbagde" & @CRLF & _
"some garbagde . 13th-16th April some garbagde" & @CRLF & _
"some garbagde . APR 13th-16th some garbagde" & @CRLF & _
"some garbagde . 13th-16th APR some garbagde"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")