#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<(\w*)>([\S\s]*?)<\/\1>"
Local $sString = "<blockquote> This is a blockquote with two paragraphs. Lorem ipsum dolor sit amet," & @CRLF & _
" consectetuer adipiscing elit. Aliquam hendrerit mi posuere lectus." & @CRLF & _
" Vestibulum enim wisi, viverra nec, fringilla in, laoreet vitae, risus." & @CRLF & _
" " & @CRLF & _
" Donec sit amet nisl. Aliquam semper ipsum sit amet velit. Suspendisse" & @CRLF & _
" id sem consectetuer libero luctus adipiscing.</blockquote>" & @CRLF & _
"" & @CRLF & _
"<blockquote> This is the first level of quoting." & @CRLF & _
"" & @CRLF & _
"<blockquote> This is nested blockquote.</blockquote>" & @CRLF & _
" Back to the first level.</blockquote>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"Not nested" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"Top level" & @CRLF & _
"<div>Nested</div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")