package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:,]+):([^:,]+)`)
var str = `key1:value1,key2:value2,key3:value3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}