import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\n\\s*(?=(?:\\d+|A)\\.[\\d+\\.]*\\.*\\s*(?:\"\\s?|“)?\\w+)";
final String string = "\\nA.8. \"text\n"
+ "\\n 8.4.2.4.1.2. text\n"
+ "\\n9.1. 12 digit and text\n"
+ "\\n9. text\n"
+ "\\n10.0.1.1. \" text\n"
+ "\\n9 text\n"
+ "\\n0.1 Hz\n"
+ "\\n 100. text\n"
+ "\\n 100.5.1. text\n"
+ "\\nA.500 text\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}