package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) \b\w+\b`)
var str = `hi my name is`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}