package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(a([0-9]))*`)
var str = `a1a3a2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}