$re = '/\bjim|john\b/i';
$str = 'Hello john, how are you doing today?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);